Figuring out 022-5432

Hello, I have not received this error personally, but I have seen a rising number of cases of it in many previous support threads, and wanted to create a thread to hopefully work together and figure out a solution to this error, even just finding out what causes it would be a huge step in the right direction, so feel free to offer insight if you’ve had this error, even if it’s just a little bit, it’ll help go a long way.



From what I can gather from what I’ve seen, it appears to be spontaneous and happen without noticeable cause, so I’m wondering if it is similar in a sense to the splatoon sssl bug

Bandwidth doesn’t have any opinion on that code, which is interesting.
We should get some basic information down.

  • Does it occur in game? When first joining a game? Does it affect Friends?
  • Does it occur when opening one of the applets?
  • If ingame, does everyone in the lobby get it?

Its a general error code. It means you can’t connect.
Are you familiar with editing your home network?

Edit: Steps would include changing WiiU and router settings

Not all error codes are known to Bandwidth. The error codes he knows about are almost entirely generated from both consoles MSBT files in their respective sysmodules. That being said, it appears as though both consoles throw errors at times (whether they were ever meant to or not) which do not have references in the MSBT files

Bandwidth actually has no information on any 022-54XX errors

For future reference, all 0XX level errors are for the 3DS

As for the actual error mentioned, it’s likely just a generic “request failed” type of error. Some more information is definitely required, as Quarky said

1 Like

that’s one thing I’ve noticed, it is quite a strange error, the earliest it’s been mentioned was 2022, and there is a gbatemp forum on it, but it’s explained as a “nnid glitch”, but offers no further information on it.

The only thing the forum confirms that the only known fix is to unlink and re-link your pnid, the problem with that fix is that it causes so many problems, most notably if you open the eshop, your games will be inaccessible, and cannot be recovered without a nand dump (to my knowledge), so I don’t believe it is a safe method to recommend to people.

The forum is here: Does anyone know what error 022-5432 is? | - The Independent Video Game Community

So far the only things I know about it is that it is an account error as it is a 022-XXXX error, furthermore, it happens mainly on accounts that are newer (at least from what I can tell by most support threads on it).

And another thing is that one time I was on my 3ds and switched to nintendo network when I had no nnid linked, it gave me the 022-5432 error, but I knew it was because it was a pnid trying to go to the nnid servers (I was trying to update a game), so if that helps (maybe if it’s a glitch where the system tries communicating with nintendo for something while on pn?), just wanted to bring it up

Hopefully we can reach the bottom of this error, I’ll try to provide as much information as I can!

Thank you very much for helping out with this!

Forgot to reply to you, my bad, I’ll try and supply the information to the best of my knowledge.

It affects generally anything, such as trying to connect to friends list (to answer your question there), but it also when people try to link their pnid, and entering juxtaposition, to name a few

I’m not 100% sure what you mean by applets, but I am assuming you mean applications like friends and juxt, if so, yes

It’s not in game as it happens before anything can connect

If there’s any further questions, please let me know

Hi, I just made a Pretendo account and I’m trying to link this account to my original 3ds (the turquoise one!) and I keep getting 022-5432 when I try to log in.
Some things to note:
This error is fatal when linking a PNID. It will close setup and send me back to System Settings.
If I select the Mii I made on my 3ds for my account to replace the default one Pretendo makes, I get a clean, bug-free exit. Nothing unusual.
If I try to make it use the basic default Mii, the system softlocks. I can summon the Rosalina menu to get a little further, but when it gets back to System Settings, it is locked up and the only way out is by holding the power button. Some nasty visual artifacting occurs during this.
This is all I know and I cannot get further than this. I hope this helps in some way!

I just realized I had to verify my account by email. I verified and tried the process one more time, same results- unsuccessful, same code

Having this same issue. I’m starting to wonder if its my 3DS. I have a Japanese New 3DS normal size. I bring this up because it was a hassle just getting it set up in English, so I wonder if its the console. I hope that’s not the case.

I doubt its the console since we have completely different systems with the same issue

1 Like

That wouldn’t be the problem, I had previously asked people the specific console, and it ranged from o3ds’ to n3ds’, so it wouldn’t be that specifically.
What confuses me the most is that the error happens, yet it doesn’t appear anywhere on Nintendo’s support page, or even in the console’s error db, which brings up a question of why it happens.

Furthermore, the known fix for it, which is not recommended to be duplicated, is to remove the nnid linked to the console, shown recommended here:

Does anyone know what error 022-5432 is? | - The Independent Video Game Community

which causes a ton of errors, but it brings up the question “why does that fix it?”, I’m wondering if it has something to do with a broken aspect of the 2nd account feature pretendo uses (?), but that’s just a guess.

I’m hoping either @PN_quarky or @PN_Jon can help figure out what’s going on with this error with the information we have so far.

1 Like

I’ve been getting this Error code since my SD Card of my 2DS got corrupted and I needed to format it again
Since then I reinstalled Nimbus it dosent really works
Nimbus itself shows that im using Pretendo even tho I switched back to Nintendo Network
My friendlist is also the one from Pretendo (My 2DS is loaded into Nintendo Network) and entering it gives me the error 002-0121
The NNID Setting are showing my NNID (not my PNID) and trying to log into anything with my NNID it gives out error 002-5432
Maby the error has something to do with Nimbus bugging out and messing up the switching between Pretendo Network and Nintendo Network?

That might make sense, as I know that 022-5432 can result from a pnid trying to contact with nn, and vice versa, so that might make some sense, although we might have to hear from a dev that knows more about it than us :slight_smile:


Maybe if it actually showed something on the screen, we could at least try to guess what it means, but no. We might have to resort to some reverse-engineering.

I created a account to find more info on this error. I’m definitely going to watch this closely as it’s a bit puzzling to me.

Small note that our stance is that you should never unlink your NNID from a 3DS at this point, especially if you have digital eShop titles, as you may lose them in the mess. We’ve had this happen before and the affected users were only able to recover by restoring a NAND backup.

1 Like

Yeah, this is why I gave the warning here

As I vividly remember the problems it caused for someone

I couldn’t reply to the original thread so I had to open a new one (am a new user)

I solved the problem! A friend suggested that I reinstall Nimbus.
I did the following to get it working:

  1. Switch back to Nintendo Network in Nimbus
  2. Uninstall Nimbus
  3. Reinstall Nimbus
  4. Switch to Pretendo in Nimbus
  5. Log in using the NNID settings in System Settings

Moved your post into the thread, welcome!