Can't seem to go online (Error code 001-0502 on 3DS)

Hello, I’ve been trying for the past days to go online and play for the first time after brewing my 3DS. However, after installing Luma, the latest Nimbus version, switching to Pretendo servers and creating a new PNID that I successfully linked to the console, it seems I still can’t play online (I tried playing Kid Icarus and MK7) and the “friend list service” indicates that I am not online. My internet connection is working fine, this is confirmed by the test connection I made (pictures) and I am able to access “Miiverse” very fine.
I’ve been stuck on this for hours, I know some people on Reddit and on this current forum met the same issue but I couldn’t find any solution that could help me.

If anyone could PLEASE help me understand the issue and help me play online again after all those years of not holding a 3DS, I would VERY MUCH appreciate it and you could make my day great again. (sorry, the console is in french, that’s my main language you see)

Here are the things I tried :

  • Reinstalling Luma to its latest version (Through universal updater and by using my computer
  • Editing the DNS (this is a solution I came across on Reddit)
  • Updating the games
  • Switching from Prentendo to Nintendo servers (back and forth)
  • Trying hours later (Days later even)

If you need any more information, do not hesitate to ask ! :slight_smile:

3 Likes

more informations !

I’m in the same boat, I just want to play mario maker & Kid Icarus online :frowning:

Aw man, how long have you been struggling with this issue ? I’ve seen you answering posts with the same issue before haha
Would you perhaps know if by upgrading to beta servers this issue can be solved ?

1 Like

It’s been a good few days sadly (I think around 3-4 at least). LOL yeah I have been posting about it, I even posted on miiverse about it :joy: Thanks for making this post; I am glad I am not the only one with this issue. Of course, I am not glad that the problem is happening, but that we are not alone lol.

I have tried everything you mentioned in your original post as well, and none of it worked. To answer your question about the beta servers, I have the same problem whether or not I am using the beta or production servers :frowning:. I have even tried taking the battery out, and that did not work. Not even redownloading the nimbus files from the github and replacing the old ones on the sd card worked, either. It’s SO weird that this is happening, because at first the servers were working for me. Hopefully we can figure this out soon

2 Likes

samething been happening to me let me know if you find a fix or if its a problem on pretendo end

4 Likes

I think It may be a Pretendo Problem. Just tried restarting my modem, and that did not work. However, I have realized that my problem is the same as yours, Jordium. Ever since I connected to Pretendo servers on my phone’s hot-spot, it now ONLY works on my hotspot.

2 Likes

Okay it randomly fixed itself after 4 days and now I’m back online

2 Likes

I don’t know what you did Jordium_Z… but you fixed mine as well

Try connecting to your pretendo, httpsmel. I wonder if it works for you now too?

I’m going to try now then haha wait

I just noticed I appear online on the friend list only when I’m connected to the nintendo server, and when I switch to pretendo I never appear online. So are you connected on Pretendo ? I’m so confused…

Beta servers won’t make a difference. Try switching to Nintendo servers and then updating Nimbus via the Universal Updater (or just replace the .cia / .3dsx with one from GitHub). If that doesn’t work, then try relinking your PNID.

My FC IS 4136 - 7164 - 7079

Indeed, this is such a strange problem… definitely scratching my head on this one. When I switched to Nintendo servers, it would also say that I was online on my friends list. When it wasn’t working for me, it would say offline on friends list when I was on Pretendo servers. Unfortunately I’m not a scientist, but maybe try connecting through a different internet connection if possible?

Okay I got a dumb problem on my console, but now i’m finally online yay T_T
My PNID : 0358-1494-6171
Thanks for assisting me through this whole thing, we’re finally out of it
EDIT : Changed the code (somehow) it’s now 3363-9049-5576

1 Like

add me back my FC is 4136 7164 7079

Wait… how do you have two friend codes? What the…

1 Like

What did you end up doing to fix it?

I’m having this issue and have no idea what to do :sob: