Wara Wara Plaza stopped working after Aroma update

Hello! Posts on Wii U menu no longer show up, after Aroma update. Is Nimble or Inkay incompatible with the latest version of Aroma (beta 19)? The Aroma changelog seems pretty big, with Maschell saying homebrew devs should switch to new APIs.

1 Like

tbh it never worked for me idk why

there are some issues with inkay with the new versions of aroma which are currently being worked on! for now some small things might not work (like this) it seems

1 Like

Use the new Inkay beta. Here’s the link:

For me to work I had to put 30_nimble.rpx in sd:/wiiu/environments/aroma/modules/setup
and unregister Wara Wara Plaza BOSS tasks from wiiu menu only on inkay plugin BOSS settings.

But then it broke on this Aroma version

Hmm… I just replaced the inkay file with the newest beta one but it doesn’t seem to work. Is there a beta nimble file too?

Not as far as I am aware…
L + Down D-Pad + Minus
Inkay → BOSS Settings → unregister Wara Wara Plaza

See if that fixes it. If not, start a game then go back to the home menu and see if that works.

1 Like

When I was testing the new Beta file, it took me a few Full Resets before it started working again.

1 Like

There is not a beta Nimble file. Last I heard, the developers are testing out an Inkay version that will completely negate the need for Nimble, entirely.

Restarting the console a few times, could help, but what has worked the most often for me, has been opening a Pretendo-supported game (Splatoon, Mario Kart, Mario Maker). After you open the game, close it and see if the Plaza is working properly again. It’s not a huge deal, as it doesn’t affect your online connectivity, but seeing the Juxt posts there is a good sign that Pretendo is actively working, so I understand the disappointment when it doesn’t work.

Checking your internet connection is always a good troubleshooting step. Something I learned recently is that if you have other devices connected on the same network as the Wii U console, and they’re physically near the console, it can impede the connection. It’s not always avoidable, but if possible, try to move laptops, phones, Nintendo Switch, etc. away from your console.


I was referring to the beta inkay file.

My apologies, with the way the forum’s UI is set up right now, it’s not clear who another user is replying to…

I was replying to a previous post from a different user, who replied to me about 24 hours ago.

Yeah, I’ve noticed that as well, it’s really weird, on other Discourse forums (although the UI is different on DevForum, uses the older sort of style), it shows the person who you’ve replied to.

Even though I’d like to consider myself knowledgeable, I don’t know what the hell is causing that to happen, might be worth looking at https://meta.discourse.org to see whether there’s anything there. Can’t find anything here at a first glance though…

1 Like

Today Aroma had another update, to version beta 20, I just opened a game and closed it and then it just worked without unresgistering boss data :stuck_out_tongue:

1 Like

There’s known to be all sorts of weird issues with the new Aroma updates. There’s a bunch of code changes almost ready to land which I’ll likely review later today. Once those are in, we can hammer out proper testing before making an updated release for everybody.

If you’re using one of the dev Inkay files downloaded from Discord, just be ready to update again once the stable version is ready.