Error code 002-0150 (3DS)

I’m having this error after some time of having the 002-0102 error code (which I think it’s a ban message).

Just to avoid already answered questions: I didn’t cheated, I apparently don’t have any disruptive homebrew installed, I didn’t modified my serial code files (double checked with the original box because my console was bought second hand) and I wasn’t banned from Nintendo 3DS online (I played till shutdown).

I have a New 2DS, thanks in advance.

UPDATE 1: Tried doing Pretendo → Nintendo → Pretendo on Nimbus, sorta worked. It letted me to log in again, did it, had some 022-2402 errors but seemed to work, even allowed me to relog on Miiverse (which it didn’t allowed me to do so) but then I’ve tried Mario Kart 7 and it throws the same error as before.

UPDATE 2: Checked and tried RTC time and date, it was ok, updated it nevertheless, still not working

UPDATE 3: Updated Luma (13.0.1 → 13.1.1), no changes. Trying to log in asked for a new password to discard communication problems between Pretendo and 3DS and the password reset mail arrived as expected, so my console doesn’t seem to have any issue connecting to Pretendo.

2 Likes

Been having this issue since I installed Nimbus. At first the message looked like a ban, but now it says it can’t connect. Friend list and pokebank works good in Nintendo network, but friends and login fails at pretendo’s network :frowning:

Have you got the latest version of Nimbus installed?

Do you know if your DNS server(s) are blocking pretendo?

Yes, I have the latest version of Nimbus.

No, I don’t have any DNS settings, and as I said, my console doesn’t seem to have any issue connecting with Pretendo (as I tried to restore password from the console and it worked)

UPDATE 4: Just in case, tried connecting to US/UM servers on Pretendo (knowing that it wasn’t going to work beyond my technical problems) and got error 022-0150, same as Mario Kart 7. Then did Pretendo → Nintendo and tried connecting to US/UM servers, got 002-0110 (Service discontinued, as expected)

UPDATE 5: Double checked with 3DSident that Original local friend code seed and NAND local friend code seed matches, and they do.

UPDATE 6: Tried setting a WiFi hotspot on my phone to discard my router messing with something (I had a similar problem with a game, was the router) but nothing changed: same errors, same issues.

Solved it following this tutorial: Discord